W3C home > Mailing lists > Public > whatwg@whatwg.org > December 2004

[whatwg] I dont like "successful"

From: Olav Junker Kjr <olav@olav.dk>
Date: Thu, 09 Dec 2004 15:16:53 +0100
Message-ID: <41B85E55.2090306@olav.dk>
Ian Hickson wrote:
> I'd love to find a better name. The attribute is needed for ATs and 
> form.validate() (to enable sane extensions in future).

I dont think "successful" is required for AT's. What is required, is 
that the AT can report to the user if a field is invalid and requires 
attention before the form can be submitted. It should use the validity 
property for this.

As for extensions, the form should be able to query some 
not-invented-yet control whether the control:

1) supports validation
2) is currently valid
3) what value(s) should be submitted (if any)

Probably a property isValidatable could be invented. It would be false 
for output, all kinds of buttons and type=hidden and type=image, true 
for the rest.

As for what values should be submitted, this can't be expressed by the 
successful boolean property. A select multiple, for example, may return 
several values.

Perhaps there could be a submissionValues property which returns a list 
of zero or more strings. These strings will be paired with the control 
name and index, and added to the datset. (An empty field will return a 
list with one element which is an empty string, while an unchecked 
checkbox will return an empty list. A select multiple may return a list 
with several values).

Olav Junker Kj?r
Received on Thursday, 9 December 2004 06:16:53 UTC

This archive was generated by hypermail 2.4.0 : Wednesday, 22 January 2020 16:58:38 UTC