Issue 619: setDirection()

Peter Thatcher said:

"I thought about this some more, and I think that if we have {direction: "sendrecv"} in the construction of an RtpTransceiver, we probably ought to have .setDirection instead of .activateSender. That would be easier to specify and would allow the application to change direction in any way (sender/receiver active/inactive)."

[BA] I agree that setDirection() would be more consistent (and succinct) than activateSender() and activateReceiver(), so I've submitted an Issue relating to this:

Also, here is a PR to add setDirection() (and remove activateSender() and activateReceiver():

Received on Thursday, 5 May 2016 01:15:17 UTC