Re: {add|remove}Track are confusing names

This is a naming debate; it's unclear that
createSender/removeSender/onreceiver are more intuitive than

That said, I agree that removeTrack(sender) is a bit awkward; we could just
as easily make that removeTrack(track || sender).

On Tue, Mar 17, 2015 at 3:09 PM, Martin Thomson <>

> I've just had a long series of conversations about these.
> RTCRtpSender addTrack(MediaStreamTrack track, MediaStream stream,
> MediaStream... others);
> The initial confusion here was that this was adding the track to the
> provided stream (ignoring the return value).  That seems relatively
> benign, except that...
> void removeTrack(RTCRtpSender sender);
> I don't even know where to start with this.  Where's the track?
> Why not?
> RTCRtpSender create[Track]Sender(MediaStreamTrack track, MediaStream
> stream, MediaStream... others);
> void remove[Track]Sender(RTCRtpSender sender);

Received on Wednesday, 18 March 2015 00:03:20 UTC