Re: replaceTrack proposal

On 3 September 2014 11:31, Peter Thatcher <> wrote:
> 1.  Why not just setTrack instead of replaceTrack?  I don't mean to
> bikeshed, but we have lots of setters in the code, and no "replacers"
> in the API.

I think that I like replace, mainly because this is an operation that
can fail.  If the source is a camera that produces a different codec,
then it is going to fail.

Rather than trigger onnegotiationneeded, I think we should make this a
silent operation that only succeeds for compatible tracks.

> 2.  Why would it matter at all what MediaStream the track is in?  I
> don't see why it would matter.  And for that matter, when would you
> have two video tracks in a MediaStream in the first place?  What does
> that even mean?

The definition of compatible tracks probably doesn't need to be
limited to tracks in the same stream.  Though the potential for the
tracks to be synchronized seems best, since if we aren't sending any
other signals, a disjoint time sequence would cause errors.

Received on Wednesday, 3 September 2014 18:40:13 UTC