Re: Update of Doohickey/AddTrack proposal

On 02/04/2014 02:13 PM, Adam Bergkvist wrote:
> Hi
> How should we proceed with this proposal? I don't think we will gain
> as much when it comes to simplicity if we just remove addStream(), but
> keep the concept of tracks belonging to a MediaStream when they are
> sent over an RTCPeerConnection (as Stefan argues in a branch of this
> thread). That was at least what I had in mind when I argued against
> addStream() in [1].

I think communicating the stream concept (which streams exist that have
this track as part of it) is important; if we don't communicate it, it's
impossible to reconstruct the streams on the receiving side.

WRT addStream(), if we add addStream(), I think we should define
addStream() in terms of addTrack(): "AddStream() must have identical
semantics to

  for track in stream.getAllTracks() {

(which also argues that we make the specification simpler if we have
getAllTracks in addition to getAudioTracks and getVideoTracks, because
we don't have to worry if a third type of track is added)

> /Adam
> [1]

Surveillance is pervasive. Go Dark.

Received on Thursday, 6 February 2014 18:31:33 UTC