W3C home > Mailing lists > Public > public-webrtc@w3.org > July 2012

Re: Summary of some ongoing discussions

From: Justin Uberti <juberti@google.com>
Date: Fri, 13 Jul 2012 00:02:02 -0400
Message-ID: <CAOJ7v-2=Nc8-3jVgjLRxzGPBUj9dyrJR8avz12Q6uDQY-+Yh=g@mail.gmail.com>
To: Stefan Hakansson LK <stefan.lk.hakansson@ericsson.com>
Cc: "public-webrtc@w3.org" <public-webrtc@w3.org>
Thanks for summarizing this. This matches my understanding, and as I see it
the main thing we need to resolve to get a stable v1 spec is whether
SessionDescription and IceCandidate should be dictionaries or objects.


On Tue, Jun 26, 2012 at 5:18 AM, Stefan Hakansson LK <
stefan.lk.hakansson@ericsson.com> wrote:

> Here is an attempt from the chairs to summarize the status of several
> on-going discussions:
>
>
> Renaming to avoid namespace issues (Anant) [ACTION-43]
>     No appetite for creative solutions like container interfaces.
>     Observation that others drop many names in the global namespace.
>     Rough consensus around a prefix for types (most likely RTC or Rtc).
>
>
> Async callbacks for SetLocal/SetRemote calls (Justin)
>     Initially this seems to be acceptable. Code that doesn’t set them will
> still work.
>     Mainly for error handling purposes - perhaps a more elegant solution
> can be found
>
>
> New state names and explicit state diagram for State / IceState
>     New names and diagrams seem acceptable
>
>
> Constraints -> option dictionaries for Create*/Set*
>     Discussion shows a need for both optionality and ordering - every
> complexity that led to constraints also applies here.
>     We should keep them as constraints structures.
>     We should update the registration doc to say that it needs to specify
> which API calls they make sense in.
>
>
> Constraints/options for addStream/addTrack
>     Some options are more related to MediaStream/MediaStreamTracks, than
> to session
>     Need to be defined
>
>
> Format of SessionDescriptions and Ice candidates
>     These are currently objects
>     There has been a proposal to move them to dictionaries instead
>     No consensus yet
>
> Adding a DataChannel object [ACTION-49]
>     Proposal written up by Randell
>     Not clear what the benefits of introducing it is
>
> Comments/feedback most welcome!
>
> Stefan for the chairs
>
>
Received on Friday, 13 July 2012 04:02:49 UTC

This archive was generated by hypermail 2.3.1 : Monday, 23 October 2017 15:19:28 UTC