Re: [webrtc-extensions] Suggestion: rename [[HeaderExtensionsToOffer]] to [[HeaderExtensionsSupported]] (#132)

setOfferedRtpHeaderExtensions strongly influences what we put in both offers and answers, but does not outright dictate what we use. I would argue that it does not do what it says on the tin, with that name. What it does is set the supported RTP extensions. From there, JSEP says we offer the supported RTP extensions minus anything that was not present in the previous answer, and JSEP says we answer with the intersection of the supported RTP extensions and what was present in the offer.

GitHub Notification of comment by docfaraday
Please view or discuss this issue at using your GitHub account

Sent via github-notify-ml as configured in

Received on Saturday, 3 December 2022 17:01:31 UTC