[webrtc-pc] Maybe RTCError doesn't have to be named "RTCError" (#2330)

jan-ivar has just created a new issue for https://github.com/w3c/webrtc-pc:

== Maybe RTCError doesn't have to be named "RTCError" ==
Since no browsers implement RTCError yet, concerns were raised about backwards 
compatibility with implementing it.

`RTCError` is both a *type* (with extra attributes), as well as the name of the error.

One idea to mitigate compat concerns would be to specify the error names browsers are using today. [E.g.](https://jsfiddle.net/jib1/r0vL78gw/):
```js
await pc.setRemoteDescription({type: "offer", sdp: "foo"}); // OperationError
```
On the upside it solves compat. On the downside, JS that cares about the attributes would need to check for them.

Please view or discuss this issue at https://github.com/w3c/webrtc-pc/issues/2330 using your GitHub account

Received on Wednesday, 16 October 2019 23:55:08 UTC