Re: [mediacapture-main] Clarify getUserMedia({audio:{deviceId:{exact:<audiooutput_device>}}}) in this specification mandates capability to capture of audio output device - not exclusively microphone input device (#650)

> The actual question I have is why would a reader conclude that it would be possible for getUserMedia() to capture from output devices when its definition mentions only input devices.

Because the table in the specification includes the plain language 

> `MediaDeviceKind` Enumeration description
> `audiooutput` | Represents an audio output device; for example a pair of headphones.

when clearly mean audio output, not exclusively audio input. `enumerateDevices()` returns a "device" labeled `"audiooutput"`. If that is not what you mean, then change that language. [This is again recording from microphone, not from audiooutput device #14](https://github.com/guest271314/SpeechSynthesisRecorder/issues/14). If you really do not mean audio output, change that to only audio input device labels. Otherwise, since `"audiooutput"` is in the specification, and it is reasonable that the authors were not writing absurd terms, audio output capture exclusively MUST be possible, else the above table would be pointless if not capable of capturing the same.

>  to select input device (i.e., microphone) associated to a particular output device (i.e., headphone).

What does "associated" meant in this case? 

This issue is about use of plain language. The specification actually provides a "description" in the case.

Propose that if `"audiooutput"` actually means what is says, then implementers MUST implement `getUserMedia()` in a way to fulfill that plain language, that is, the capability to capture only audio output - while recognizing that you insist on indicating that `getUserMedia()` only deals with input, fine, call it input, just provide the means to do what the plain language says, or call it something else - else, change the language to state you really mean _only_ input devices, and stick to that.









-- 
GitHub Notification of comment by guest271314
Please view or discuss this issue at https://github.com/w3c/mediacapture-main/issues/650#issuecomment-564343266 using your GitHub account

Received on Wednesday, 11 December 2019 02:02:24 UTC