[webrtc-stats] Rename "objectDeleted" to something else.

henbos has just created a new issue for https://github.com/w3c/webrtc-stats:

== Rename "objectDeleted" to something else. ==
In the case of "track" stats, "objectDeleted" would be true for any attachments that are no longer current, even though no object has necessarily been deleted. Neither "object" or "deleted" are suitable descriptions unless you consider the "attachment" the "deleted object".

Generally speaking, any object that is exposed to the application may not have been deleted due to existing references (by application or webrtc) ((or if we want to be pedantic, because the GC has not run)).

This may be bikeshedding but if we want to rename it we should do so now before UAs ship it.
What's more suitable? "active" or "isActive"? (RTCTransportStats.active has since long been removed from the spec)

Please view or discuss this issue at https://github.com/w3c/webrtc-stats/issues/296 using your GitHub account

Received on Thursday, 11 January 2018 17:20:32 UTC