- From: Wan-Teh Chang <wtc@google.com>
- Date: Thu, 25 Oct 2012 16:22:40 -0700
- To: Ryan Sleevi <sleevi@google.com>
- Cc: Web Cryptography Working Group <public-webcrypto@w3.org>, Vijay Bharadwaj <Vijay.Bharadwaj@microsoft.com>
I checked in my proposed comment change in /w3ccvs/WWW/2012/webcrypto/WebCryptoAPI/Overview.html, rev. 1.40. See http://www.w3.org/2012/webcrypto/WebCryptoAPI/#aes-ctr-params On Tue, Oct 16, 2012 at 10:58 AM, Wan-Teh Chang <wtc@google.com> wrote: > > We can solve [the ambiguity of the name "length"] by improving the comments: > > dictionary AesCtrParams : AlgorithmParameters { > // The initial value of the counter block. |counter| MUST be 16 bytes. > ArrayBuffer counter; > // The length, in bits, of the part of the counter block that is incremented > [EnforceRange] octet length; > }; > > but it would be nice to improve the name for "length", too. How about renaming "length" to "incrBits"? By the way, the "generator" key in the DhKeyGenParams dictionary could also be shorted to "base": dictionary DhKeyGenParams : AlgorithmParameters { // The prime p. BigInteger prime; // The base g. BigInteger generator; }; http://www.w3.org/2012/webcrypto/WebCryptoAPI/#dh-DhKeyGenParams Wan-Teh
Received on Thursday, 25 October 2012 23:23:07 UTC