W3C home > Mailing lists > Public > public-webcgm@w3.org > December 2008

Response to WebCGM 2.1 Last Call comment: WebCGMRect::union

From: Lofton Henderson <lofton@rockynet.com>
Date: Thu, 18 Dec 2008 11:13:22 -0700
Message-Id: <>
To: bbezaire@ptc.com
Cc: public-webcgm@w3.org

Dear Benoit,

The WebCGM Working Group has reviewed the comment you sent [1] about the 
WebCGM 2.1 Last Call Working Draft [2] published on 02 October 2008.  Thank 
you for having taken the time to review the document and send us comments.

The Working Group's response resolution to your comment is included below.

Please review it carefully and acknowledge this WebCGM WG response by 
replying to this mail and copying the WebCGM public mailing list 
<public-webcgm@w3.org>. Let us know if you agree with it or not before 11 
Jan 2009.  If we receive no reply from you by January 11, then we will 
default your reply to "WebCGM WG response accepted."

In case of disagreement, you are requested to provide a specific solution 
for or a path to a consensus with the Working Group.

If such a consensus cannot be achieved, you will be given the opportunity 
to raise a formal objection which will then be reviewed by the Director 
during the transition of this document to the next stage in the W3C 
Recommendation Track.

Best regards,

On behalf of the WebCGM Working Group,
Lofton Henderson, WebCGM WG Chair.

[1] http://lists.w3.org/Archives/Public/public-webcgm-wg/2008Oct/0000.html
[2] http://www.w3.org/TR/2008/WD-webcgm21-20080917/
* Comment Sent: Thu, 2 Oct 2008
* Archived:

The WebCGM WG has the following responses to your comment:

SUMMARY of your comment:

>union() is not a good method name. Given that 'union' is a C/C++ keyword, 
>it cannot get compiled by the MIDL compiler (on Windows).We need a new 
>name. Either:i) Union(): but we have so far, started method names using 
>lower cap characters.ii) calcUnion() or getUnion(): or something similar.
>Follow-on comment:
>"Don proposed 'unionRect()'. I'm fine with that. [...] Benoit"

RESPONSE to your comment:

>Change the method name 'union()' to 'unionRect()', as proposed. Changes 
>will be made in:, 5.7.5 (setView), and Ch.8 (ECMAScript).

--------------------------- end -------------------------------
Received on Thursday, 18 December 2008 18:14:15 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 18:59:15 UTC