W3C home > Mailing lists > Public > public-webauthn@w3.org > October 2017

Re: [webauthn] #getAssertion alg needs to pass authenticator selection requirements to authenticatorGetAssertion operation

From: Emil Lundberg via GitHub <sysbot+gh@w3.org>
Date: Thu, 26 Oct 2017 10:28:38 +0000
To: public-webauthn@w3.org
Message-ID: <issue_comment.created-339622824-1509013717-sysbot+gh@w3.org>
I propose renaming the `NotRequired` enum value to `Forbidden`. `NotRequired` is confusing because logically speaking "not required" is equivalent to "allowed, but not required". `Forbidden` on the other hand unambiguously communicates "not required _and_ not allowed".

-- 
GitHub Notification of comment by emlun
Please view or discuss this issue at https://github.com/w3c/webauthn/issues/644#issuecomment-339622824 using your GitHub account
Received on Thursday, 26 October 2017 10:28:40 UTC

This archive was generated by hypermail 2.4.0 : Tuesday, 5 July 2022 07:26:29 UTC