RE: Can not find any browser that works ...

FWIW, ‘webassemblydemo’ failed on latest Firefox 52 (snapshot attached) on my Toshiba PORTEGE Z930-14C laptop (compiling web assembly step apparently seems to be successful). I am able to run ‘Tanks’ demo though.


From: John Henry []
Sent: 07 March 2017 21:17
To: David Ross;
Subject: Re: Can not find any browser that works ...

Hey Doug,

Web assembly just went live in Firefox 52 today. You should be able to download the latest version today and run that demo.
Here's another interesting demo:

-- John

On Mon, Mar 6, 2017 at 2:26 AM David Ross <<>> wrote:
WASM is being switched on from Firefox 52 (7 March, 2017). Chrome will follow the next version rollout, the next week possibly?

I'm using Nightly (54) on Arch Linux on a 2008 model Dell laptop running 16Gb RAM and

1) now works fine. It did not a few months back when I last tested.
2) not sure of your precise test here to compare

On Thu, 2017-03-02 at 09:25 -0700, Doug Royer wrote:

Just started playing with wasm.

Tried several version of Firefox and Chrome.

     Running Linux, Fedora-24


        Starts up a loading page, then after the load slider is

finished, products a BLANK page

(2) The HelloWorld demo, generates:

An Exception thrown, see JavaScript console, on the browsers.

(2.1) the "emrun --no_browser --port 8080 ."

prints this when the browser access the page:

     The html page you are running is not emrun-capable. Stdout,

     stderr and exit(returncode) capture will not work. Recompile

     the application with the --emrun linker flag to enable this, or

     pass --no_emrun_detect to emrun to hide this check.

(2.2) Compiling with "--emrun", produces the same error as (2)

(2.3) Compiling with "--no_emrun_detect", results in (at compile time)

     clang-3.9: error: unsupported option '--no_emrun_detect'

     ERROR:root:compiler frontend failed to generate LLVM bitcode,



     What browsers versions work?

     Are the



Received on Wednesday, 8 March 2017 14:51:49 UTC