Re: FileReader: rename onload to onsuccess

On 01/08/2016 07:06 PM, Juraj Maracky wrote:
> Hello,
> I propose to rename FileReader's load event to success. This way it is much easier to remember and mentally group FileReader's events:
> error - success; loadstart - loadend; progress - abort.
> Also, this would clarify potential confusion with loadend.
> Thanks,
> Juraj

'load' has been there for years now, so it can't be removed, and adding another event doesn't
really make the API better.

And 'load' follows the suggested event names from
so there is some consistency with the events in XMLHttpRequest.


Received on Monday, 11 January 2016 22:06:29 UTC