- From: Dominique Hazael-Massieux <dom@w3.org>
- Date: Wed, 18 Sep 2013 10:52:44 +0200
- To: public-webapps@w3.org
Hi, While parsing en-masse some of the IDLs in JavaScript APIs out there, I stumbled upon an incorrect IDL in https://dvcs.w3.org/hg/streams-api/raw-file/tip/Overview.htm#error-uris_for_streams First, the stream API should not redefine the URL interface, but instead define the additional method it needs on a partial interface. Second the "object" parameter of createObjectURL should be prefixed with an underscore since object is a reserved keyword in WebIDL. Although with a separate overloaded method for stream, using another name for the parameter will probably work better. As a result, it should probably looks like partial interface URL { static DOMString createObjectURL (Stream stream) }; HTH, Dom
Received on Wednesday, 18 September 2013 08:52:59 UTC