RE: [Window/View Modes] Naming + Feature vs. Query: suggested changes

Hi Marcos,

Thanks for your comments.

>>Can we just call it "view-mode"?
>>Again, just "viewMode"
Actually I was thinking about it and got stick to the widget environment with view modes due to the following:
if the spec would be generic for "any" view modes, then "view-mode" and "viewMode" would be ok. But since we remain in the context of widgets (family and title of the spec) I kept the "widget" prefix. If someone in future would use similar mechanisms with e.g. "application", she/he would use "application-view-mode" etc.

To clarify your position finally:
should this:

> interface WidgetViewModeChangeEvent : Event {
>  readonly attribute DOMString widgetViewMode;
> ...
> };

be changed to

> interface ViewModeChangeEvent : Event {
>  readonly attribute DOMString viewMode;
> ...
> };

(it is about the name of the interface) ??

Do we care about "non-widgets" using view modes?


Kind regards,

Marcin Hanclik
ACCESS Systems Germany GmbH
Tel: +49-208-8290-6452  |  Fax: +49-208-8290-6465
Mobile: +49-163-8290-646

-----Original Message-----
From: [] On Behalf Of Marcos Caceres
Sent: Tuesday, August 18, 2009 12:24 PM
To: Marcin Hanclik
Subject: Re: [Window/View Modes] Naming + Feature vs. Query: suggested changes

On Tue, Aug 18, 2009 at 11:06 AM, Marcin
Hanclik<> wrote:
> Hi All,
> I am now editing the Window Modes document.
> It seems there is inconsistency in the naming of core subject of the Window/View Modes specification.
> P&C uses "viewmodes" XML attribute [1].
> P&C refers to: "[Widgets-Views] Widgets 1.0: Media Query Extensions."
> WM has the title "Window Modes and ..." [2].
> WM uses in CSS "widget-mode" features [2] and "widgetMode" attribute [3].
> A&E uses "viewMode" Web IDL attribute [4].
> My suggestion is to unify the related naming convention.
> IMHO, the spec defines new media feature (widget-mode/widget-viewmode) [5], but does not define new media queries or their new syntax [6].
> So we should add the proper title to reflect this fact.
> E.g.
> @media handheld and (widget-mode: widget) and (orientation: landscape) {
> }
> is proper MQ syntax [6].
> The suggested changes are:
> 1. Rename the specification to:
> "Widgets 1.0: View Modes and Media Features"
> a. The link "" could be changed to ""

I support this change

> 2. Rename the media feature from "widget-mode" to "widget-view-mode".\

Can we just call it "view-mode"?

> 3. Modify the Web IDL IF from
> interface WidgetModeChangeEvent : Event {
>  readonly attribute DOMString widgetMode;
> ...
> };
> to
> interface WidgetViewModeChangeEvent : Event {
>  readonly attribute DOMString widgetViewMode;
> ...
> };

Again, just "viewMode"

> I would like to proceed with these editorial changes asap (e.g. have it done before our next telco), and I just would like first to consult with the group whether there are any objections or comments wrt the above modifications.

As far as I am concerned, go forth and spec! :)

Marcos Caceres


Access Systems Germany GmbH
Essener Strasse 5  |  D-46047 Oberhausen
HRB 13548 Amtsgericht Duisburg
Geschaeftsfuehrer: Michel Piquemal, Tomonori Watanabe, Yusuke Kanda

This e-mail and any attachments hereto may contain information that is privileged or confidential, and is intended for use only by the
individual or entity to which it is addressed. Any disclosure, copying or distribution of the information by anyone else is strictly prohibited.
If you have received this document in error, please notify us promptly by responding to this e-mail. Thank you.

Received on Tuesday, 18 August 2009 11:28:46 UTC