Re: FileAPI "splice" method

Adam de Boor wrote:
> this is a minor point, but I'm finding the name of the "splice" method to be
> odd. To me splice means to join, and "slice" would seem a more appropriate
> name. The Array object has both splice and slice, and the former is used for
> removing and inserting data and modifies the array in place, while the
> latter pulls out a sub-part of the array into a new array.
> a
Agreed -- the  method is renamed.  "splice" was just a clumsy choice for 
a name on my part :-)

-- A*

Received on Wednesday, 12 August 2009 14:53:30 UTC