[Bug 25343] Expose an isClosed property on Blob Objects

https://www.w3.org/Bugs/Public/show_bug.cgi?id=25343

--- Comment #9 from Glenn Maynard <glenn@zewt.org> ---
Having to type "!" doesn't matter, and "readable" suggests that it might be
connected to things other than the blob being closed, such as whether a user
file underlying a File is still accessible (which it wouldn't).

(Actually, you'd be adding that one ! character in my code, not removing it,
since I try to write "if(blob.isClosed) return; ...", not "if(!blob.isClosed) {
... }".  Flat code is generally easier to follow than heavily nested code.)

But, yeah, this is a case of "it seems like it would make sense to have this
feature, let's think up reasons to add it".  That's not always a bad thing,
since you can find legitimate use cases that you might have otherwise missed,
as long as it's dropped if use cases don't actually materialize.  This can
always be added later if they do.

-- 
You are receiving this mail because:
You are the QA Contact for the bug.

Received on Tuesday, 6 May 2014 14:40:44 UTC