Priority Hints - merge with Lazyload?

Best to hold the discussion on the Github issue
<> and I know there was a
bunch of bikeshedding to get to "importance" as the attribute for priority
hints but I am starting to think that it would be cleaner if we added 2
enums to "loading" instead to handle the high/low priority cases.

Something like loading=urgent for high-priority resources and loading=idle
for low-priority resources. There's no overlap between lazyload and
priority hints where you'd want to enable lazyload and also set a specific
priority so it's a pretty natural fit.

That will also help make sure we stay focused on the attribute only
applying to the loading of the resource and keep the explosion of
attributes in check.

Received on Monday, 1 November 2021 14:46:46 UTC