Re: [RequestAnimationFrame] cancelRequestAnimationFrame is an odd name

On 12/7/11 12:59 AM, James Robinson wrote:
> Either sound fine to me.  The goal is to attempt some sort of symmetry
> with setTimeout/clearTimeout and setInterval/clearInterval.  I'm not
> sure if "request"/"cancel" are an ideal pair but I didn't come up with
> the "request" bit in the first place :).

If we have a better name, we should consider it now, before 
implementations start unprefixing.  Content that was trying to be 
forward-compatible with the unprefixed name will need to be changed, of 
course, but it all has fallbacks to setTimeout anyway, so it won't fail 


Received on Wednesday, 7 December 2011 06:07:38 UTC