- From: James Simonsen <simonjam@chromium.org>
- Date: Thu, 18 Aug 2011 12:52:22 -0700
- To: public-web-perf <public-web-perf@w3.org>
- Message-ID: <CAPVJQin44uBN-JpOyj5cyWqgyT8OPpnAFzGdj-LbdSUVw0y39w@mail.gmail.com>
I've been looking at implementing this again and made notes of some things we might want to change in the spec. Let me know what you think. "The startTime attribute must return..." - Why doesn't this just return fetchStart? I'd like the range [startTime, startTime + duration] to encompass all of the values in the struct (except for the zeroed out ones). As it is now, fetchStart may occur before startTime. "The duration attribute must return a timestamp equal to the difference between responseEnd and startTime, respectively." - This can be simplified to: "The duration attribute must return the difference between responseEnd and startTime." "redirectStart attribute" "redirectEnd attribute" - Can we put "Otherwise, ..." into its own paragraph? It'd make it easier to read, since each paragraph handles one condition. Rest of the attributes (domainLookupStart, etc.) - Can we make these follow the same "if this..., if that..., otherwise..." structure as the redirect attributes? Right now, you just read the first paragraph and think you're done, not realizing there are exceptions listed after that. - Can we simplify the wording around the Timing-Allow-Origin? Maybe something along the lines of, "if the resource's origin doesn't satisfy the [resource origin check], return 0." Where [resource origin check] is a link to a separate section. "void setResourceTimingBufferSize (in unsigned long maxSize);" - No space before the opening parenthesis. "The callback onresourcetimingbufferfull is triggered when the buffer used to store the list of PerformanceResourceTiming is full" - This should be more tightly defined: "The callback onresourcetimingbufferfull is called immediately after a resource is added to the buffer if the buffer size now equals the capacity." Or something along those lines. - It's not immediately clear from reading the text, but I think the intent is that this only fires once when the buffer becomes full and not for every resource loaded after that. We shouldn't spam developers with events if they don't care about Resource Timing. "Have a value in the range of 100 to 200." - We have a 65K range. How about we push this out? Maybe make the high bit indicate it's vendor prefixed (32K - 64K). Thanks, James
Received on Thursday, 18 August 2011 19:52:46 UTC