Re: updated Editor's Draft

This is great! Comments:

About the tag property:

> The user agent should not allow two notifications created by the same security origin and having the same tag value to be shown simultaneously, by comparing at the point that the notification is created.

I think the last clause is unnecessary, since that sounds like an implementation detail.

> close
> Requests the user agent to close this notification. If the notification has already been displayed, the user agent must remove it from the display; if it has not yet be displayed, the user agent must prevent its being displayed.
> 
A clearer rewording, perhaps: "If the notification has already been displayed, the user agent must remove it from the display; otherwise, the user agent must prevent it from being displayed."

> Notification
> Returns a new simple notification object with the provided content.
> 

I think something about the platform showing the notification should be mentioned here, even if it's explained later. Or move those sentences at the end of the section into this part?

Also, can we add a link to the spec that talks about tasks? And maybe provide another example that shows how that can be leveraged in code (by assigning event listeners after the constructor)?

> body of type DOMString
> The value contains the secondary text, or body, of the notification.
> The user agent must process any markup in this string it so that it appears as plain text when used as a string in the underlying notification platform.
> 

Extra "it" in the last sentence. "used by the underlying notification platform" for clarity (ditto for title).

The algorithms in 6.4 and 6.5 should use a conditional for iconUrl. (Something like: If specified, fetch the resource given by iconUrl, etc... Otherwise, skip to step 3.)

Section 6.1: "the device allows notifications to _be_ displayed immediately"

Section 6.5: platform is misspelled in step 4b.

Section 7.2: The second notification should probably have a different title, so that it is clear that the title the user sees is from the second notification, not the first.

Section 7.3: The last sentence should probably mention that this would be an issue for notification platforms that support queueing, where the oldest notifications are shown. Using close() would be a suitable approach for platforms that show the newest notifications.

Section 8: Reference to web workers and cors is unneeded. 

Jon

Received on Wednesday, 11 April 2012 17:40:27 UTC