Re: [tvcontrol-api] Why retrieve a list of tuners instead of just one tuner?

Thanks for the update, @stevem-tw. The new API follows the IDL we've 
discussed at length in this issue, so that looks good to me :)

I note a few inconsistencies in the spec below. Some of them can be 
fixed right away. Some of them could be addressed in separate issues 
later on:

- Given that the notion of tuner disappears from this redesign, I 
would drop the `TVSource.tuner` property and the `TVTuner` interface 
right away, otherwise the spec is somewhat confusing. The `stream` 
property should move to `TVSource`.
- Similarly, the `tunerchanged` event should be dropped. This begs the
 question as to what happens when a tuner is added/removed. Most 
probably the list of channels changes, which would trigger a 
`channellistchange` event (which does not exist yet). Or capabilities 
change and we need to create a `capabilitieschange` event, but that 
sounds a bit overkill: when are tuners added/removed? E.g. does that 
really happen without restarting the device?
- I see you put `<dfn>` within IDL blocks, for instance for 
`TVSourceCapabilities`, `TVSourceConstraints`.. This confuses ReSpec 
and breaks links to the underlying dictionary and interface. The 
`<dfn>` should rather be with the wrapping header, as in: 
`<h2><dfn>TVSourceConstraints</dfn>` Interface</h2>`.
- In `TVSourceCapabilities`, `deliverySystem` should be of type 
`sequence<TVSourceType>` to target the enumeration, not 
`sequence<DOMString>`.
- In `TVSourceConstraints`, `deliverySystem` is defined as `boolean`. 
I think it should of type `TVSourceType` (or perhaps 
`sequence<TVSourceType>` if we can think of use cases where 
applications will want to request more than source type at a time.
- In `TVSource`, what does `getSettings` do? It seems a duplicate of 
`getConstraints`. I would drop it and drop `TVSourceSettings` as well.
- In `TVControl`, I would rather have one `getManager` method that 
takes a parameter of type `TVManagerType`, which would be a short enum
 with "tv" and "radio". I believe it is cleaner than having two 
separate methods.

-- 
GitHub Notification of comment by tidoust
Please view or discuss this issue at 
https://github.com/w3c/tvcontrol-api/issues/4#issuecomment-277255940 
using your GitHub account

Received on Friday, 3 February 2017 14:14:33 UTC