W3C home > Mailing lists > Public > public-swd-wg@w3.org > January 2008

Label relations confusingly named?

From: Thomas Baker <baker@sub.uni-goettingen.de>
Date: Tue, 8 Jan 2008 14:06:10 +0100
To: SWD Working Group <public-swd-wg@w3.org>
Message-ID: <20080108130610.GA5344@octavius>

The draft SKOS Reference [1] very helpfully points out the
symmetry between mappingRelation (with its subproperties
broadMatch, narrowMatch, and relatedMatch) and semanticRelation
(with its subproperties broader, narrower, and related).

However, I find that this naming pattern subtly gets in the
way of grasping the much different concept of label relations.
The problem becomes clear if one puts the names side-by-side:

    Properties:   labelRelated    mappingRelation  semanticRelation
    Classes:      LabelRelation

I cannot think of a better name than LabelRelation, but I would
find it less confusing if labelRelated were renamed relatedLabel:

    Properties:   relatedLabel    mappingRelation  semanticRelation
    Classes:      LabelRelation


[1] http://www.w3.org/2006/07/SWD/SKOS/reference/20071223

Tom Baker - tbaker@tbaker.de - baker@sub.uni-goettingen.de
Received on Tuesday, 8 January 2008 13:07:22 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:31:47 UTC