W3C home > Mailing lists > Public > public-svg-wg@w3.org > January to March 2010

Re: SVG 1.1F2 testsuite update

From: Erik Dahlstrom <ed@opera.com>
Date: Mon, 15 Mar 2010 11:12:40 +0100
To: anthony.grasso@cisra.canon.com.au
Cc: "public-svg-wg@w3.org" <public-svg-wg@w3.org>
Message-ID: <op.u9ltbehzgeuyw5@localhost>
On Mon, 15 Mar 2010 10:04:56 +0100, Anthony Grasso  
<anthony.grasso@cisra.canon.com.au> wrote:

> Hi Erik,
>
> I've started putting a dent in that list of issues with the testsuite.  
> Please see comments below.
>
> Erik Dahlstrom wrote:
>>  Hello svg-wg,
>>  I've just finished my run over the 1.1F2 testsuite, fixing a bunch of
>> issues in the process. I've noted some of the still unfixed things  
>> below.
>>  General comments:
>> - The old testcase descriptions are not up-to-date with the new  
>> template,
>> we need to decide how to proceed.
>> - We need a disclaimer somewhere for the tests that are in draft status,
>> on main page maybe? Or on each page that contains a draft test?
>> - Note to self: I made a few mistakes when checking in some of the new
>> references, I need to make sure they all have the -kb flag.
>>  animate-elem-24-t.svg
>> seems to have lost its svgfont in the template converstion process
> FIXED - Basically due to a flaw in the conversion script.
>
>>  animate-elem-42-t.svg
>> animate-elem-43-t.svg
>> animate-elem-45-t.svg
>> animate-elem-47 - up to ...51-t.svg
>> empty tests
> FIXED - removed tests.
>
>>  animate-elem-60-t
>> reference image should probably show all rects as green, so needs
>> patchimage
> FIXED - created an image patch for this.
>
>>  animate-elem-77-t.svg
>> needs italic and bold faces for the SVGFreeSans svgfont
> I think this was already fixed when I looked at it
>
>>  color-prop-04-t.svg
>> color-prop-05-t.svg
>> is accepted but has the draft mark
> FIXED - commented out the draft watermark.
>
>>  conform-viewers-01-t.svg
>> needs reference image
> FIXED - checked one in. Although, I'm just wondering if we need an image  
> patch for this. The Batik squiggle viewer seems to render this file  
> correctly.
>
>>  coords-viewattr-01-b.svg
>> needs reference image, needs imagepatch
>>
> FIXED - checked in a PNG image patch. Once again, the Batik squiggle  
> viewer seems to render this file correctly.
>
>> filters-blend-01-b.svg
>> wrong scale on viewbox? both svg and reference wrong
> Already fixed.
>
>>  filters-color-02-b.svg
>> filters-conv-02-f.svg
>> filters-light-02-f.svg
>> reference has draft mark, but otherwise looks ok
> FIXED - checked in new reference images for these. Will we need image  
> patches for these as well?
>
>>  filters-felem-02-f.svg
>> filters-offset-02-b.svg
>> needs imagepatch
> FIXED - checked in an imagepatch for each test.

Nice work!

Could you please update the wikipage with the progress too? Easier to  
track that way.

   http://www.w3.org/Graphics/SVG/WG/wiki/Test_Suite_1.1F2

Cheers
/Erik

-- 
Erik Dahlstrom, Core Technology Developer, Opera Software
Co-Chair, W3C SVG Working Group
Personal blog: http://my.opera.com/macdev_ed
Received on Monday, 15 March 2010 10:06:57 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:29:43 UTC