- From: Phil Adams <phil_adams@us.ibm.com>
- Date: Tue, 27 Jan 2009 13:28:02 -0600
- To: public-soap-jms@w3.org
- Message-ID: <OF67177662.6FF6F762-ON8625754B.00692FA7-8625754B.006AED74@us.ibm.com>
In section 2.2.1 of the SOAP/JMS binding spec, we use " javax.naming.Context.INITIAL_CONTEXT_FACTORY" to refer to a property in the definition of the soapjms:jndiInitialContextFactory parameter, yet we use "java.naming.provider.url" to refer to a property in the definition of the soapjms:jndiURL parameter. >From a pure specification standpoint, I can see how we would want to use the actual property names as specified in the JNDI specification. Those names would be "java.naming.factory.initial" and "java.naming.provider.url". However, from a programmer's perspective, I can also see how we would want to specify the constants since we all know it is good practice to use constants for things like this. With this in mind, I'll propose two separate wordings and we can discuss on the next call or via email and vote: Proposal #1: a) soapjms:jndiInitialContextFactory: This is mapped to the "java.naming.factory.initial" property (defined by constant javax.naming.Context.INITIAL_CONTEXT_FACTORY) to be set in the HashMap passed to an InitialContext constructor. b) soapjms:jndiURL: Specifies the JNDI provider URL, which is mapped to the java.naming.provider.url property (defined by constant javax.naming.Context.PROVIDER_URL) to be set in the HashMap passed to an InitialContextconstructor. Proposal #2: a) soapjms:jndiInitialContextFactory: This is mapped to the "java.naming.factory.initial" property to be set in the HashMap passed to an InitialContext constructor. b) soapjms:jndiURL: Specifies the JNDI provider URL, which is mapped to the java.naming.provider.url property to be set in the HashMap passed to an InitialContextconstructor. So, proposal #1 would be to essentially specify both with "(defined by constant X)" included in the sentence, and proposal #2 would be to only specify the actual property names. I think I would lean toward proposal #1 just to be painfully clear to the reader, but I'm fine with either way... One other minor editorial change: In section 2.2.2.1, the programming example should be changed such that the first "import" statements reads "import javax.naming.Context" (i.e. it should be javax, not java). Regards, Phil __________________________________________________________________________________________________________ Phil Adams phil_adams@us.ibm.com WebSphere Application Server Office: (512) 286-5041 (t/l 363) Web Services Development Mobile: (512) 750-6599 IBM - Austin, TX
Received on Tuesday, 27 January 2009 19:28:59 UTC