W3C home > Mailing lists > Public > public-secondscreen@w3.org > August 2015

Re: Renaming "Session" to "Connection"

From: Anton Vayvod <avayvod@google.com>
Date: Mon, 24 Aug 2015 21:28:18 +0100
Message-ID: <CAOjek6qd=0Hr_Gx9XmvbEQEXZ+w-XA0zkZPrXEDwxpyu-3Y_Yg@mail.gmail.com>
To: Jonas Sicking <jonas@sicking.cc>
Cc: "mark a. foltz" <mfoltz@google.com>, "public-secondscreen@w3.org" <public-secondscreen@w3.org>
I filed https://github.com/w3c/presentation-api/issues/171 to track the
renaming.

On Tue, Aug 11, 2015 at 3:50 AM, Jonas Sicking <jonas@sicking.cc> wrote:

> On Mon, Aug 10, 2015 at 4:53 PM, mark a. foltz <mfoltz@google.com> wrote:
> > I do agree with this.   "Session" implies that the lifetime of the
> > PresentationSession is tied to the lifetime of the presentation.  It's
> not;
> > the "sessions" are really "connections" that are tied to the lifetime of
> a
> > specific opener/controller that may become disconnected.
> >
> > I was thinking that PresentationController also makes sense in this
> context.
> >
> > It depends a bit on the meaning of .close(): does it close a specific
> > controller's connection, or does it terminate the presentation?  See [1].
> >
> > [1] https://github.com/w3c/presentation-api/issues/35
>
> This is a good question. I'll comment in the issue.
>
> / Jonas
>
> > m.
> >
> >
> > On Fri, Aug 7, 2015 at 12:08 AM, Jonas Sicking <jonas@sicking.cc> wrote:
> >>
> >> Hi!
> >>
> >> Another bikeshed issue. Feel free to simply downvote this one since I
> >> realize that it's a big change which might not be worth it since it's
> >> a name change.
> >>
> >> I feel like the term "Session" is a bit confusing. To me a "session"
> >> is more like "the time between when an application starts and when it
> >> is shut down".
> >>
> >> During that period of time one or more "Connections" can be made to
> >> the application from user devices. These connections might temporarily
> >> get disconnected, but that doesn't abort the "session".
> >>
> >> Additionally multiple people might connect to the application. Each of
> >> these is a "Connection" connecting to the "session" on the TV.
> >>
> >> So it would make a lot of sense to me to rename "Session" to
> >> "Connection" in the various APIs. Including renaming
> >> "PresentationSession" to "PresentationConnection",
> >> "onsessionavailable" to "onconnectionavailable" and "getSession(s)" to
> >> "getConnection(s)", etc.
> >>
> >> Again, feel free to ignore this if you feel that you disagree, or that
> >> the spec churn isn't worth it.
> >>
> >> / Jonas
> >>
> >
>
>
Received on Monday, 24 August 2015 20:29:06 UTC

This archive was generated by hypermail 2.3.1 : Monday, 24 August 2015 20:29:07 UTC