W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

Re: [WebIDL] Simplify callbacks

From: Anne van Kesteren <annevk@opera.com>
Date: Thu, 10 Nov 2011 12:27:11 -0800
To: "Jonas Sicking" <jonas@sicking.cc>
Cc: "public-script-coord@w3.org" <public-script-coord@w3.org>
Message-ID: <op.v4p93lbh64w2qv@annevk-macbookpro.local>
On Thu, 10 Nov 2011 00:06:49 -0800, Jonas Sicking <jonas@sicking.cc> wrote:
> As others have pointed out, I think this is entirely the wrong direction  
> to go.
> The whole point of being able to pass in an object and have a function
> called on that object is to allow the page to have an object which
> registers as a listener to several callbacks and reacts to all of them
> appropriately.
> If you are just listening to a single callback you might as well use a
> function with a closure.
> However if all callbacks use the same function name, then we've lost
> all advantages of using an object with member functions since all
> callbacks would go to the same member function.
> Instead we should encourage callbacks to use descriptive names for the
> callback function so that it makes sense to have a observer object
> which listens to multiple callbacks using separate functions.

Given the many many callbacks that use handleEvent() it seems that ship  
has sailed.

Anne van Kesteren
Received on Thursday, 10 November 2011 11:27:56 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:04 UTC