W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

Re: [WebIDL] Simplify callbacks

From: Robin Berjon <robin@berjon.com>
Date: Wed, 9 Nov 2011 17:30:04 +0100
Cc: public-script-coord@w3.org, "Olli Pettay" <Olli.Pettay@helsinki.fi>, olli@pettay.fi
Message-Id: <FD0D80C0-A2DF-4BD3-9916-A5CBFA31D0A8@berjon.com>
To: Anne van Kesteren <annevk@opera.com>
On Nov 9, 2011, at 16:18 , Anne van Kesteren wrote:
> On Tue, 08 Nov 2011 13:37:16 -0700, Olli Pettay <Olli.Pettay@helsinki.fi> wrote:
>> On 11/08/2011 04:47 PM, Anne van Kesteren wrote:
>>> It seems that all callbacks use handleEvent() and we cannot change that
>>> at this point I think.
>> MutationObserver proposal has handleMutations(),
>> animationframes has sample(), IndexedDB has transactionStarted() etc.
>> So, no, all the callbacks don't use handleEvent(), and that is actually bad name for APIs which aren't handling events but some other data.
> So some new APIs that can still be changed are not using handleEvent(). That does not seem like a good idea to me given everything else we have. That only a couple of new APIs are doing this (and Indexed DB only recently, TR/ does not have it) suggests someone has been shopping this idea around, but I do not think there is wide agreement for it.

Well, we discussed this last week and there was rather broad agreement that it was a good idea to enable sensible names... I don't want to rathole, but I'd rather not build a limitation to handleEvent() into WebIDL.

Robin Berjon - http://berjon.com/ - @robinberjon
Received on Wednesday, 9 November 2011 16:30:33 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:04 UTC