W3C home > Mailing lists > Public > public-script-coord@w3.org > October to December 2011

Re: [WebIDL] Simplify callbacks

From: Olli Pettay <Olli.Pettay@helsinki.fi>
Date: Tue, 08 Nov 2011 22:37:16 +0200
Message-ID: <4EB992FC.8030902@helsinki.fi>
To: public-script-coord@w3.org
On 11/08/2011 04:47 PM, Anne van Kesteren wrote:
> It seems that all callbacks use handleEvent() and we cannot change that
> at this point I think.

MutationObserver proposal has handleMutations(),
animationframes has sample(), IndexedDB has transactionStarted() etc.
So, no, all the callbacks don't use handleEvent(), and that is actually 
bad name for APIs which aren't handling events but some other data.


> We should simplify callback syntax to a) make IDL
> easier to read and b) ensure consistency throughout the platform.
> addEventListener(DOMString type, Callback(Event)? listener, optional
> boolean capture)
Received on Tuesday, 8 November 2011 20:37:44 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:04 UTC