W3C home > Mailing lists > Public > public-script-coord@w3.org > July to September 2011

Re: [Webidl] editorial comments

From: Cameron McCormack <cam@mcc.id.au>
Date: Mon, 05 Sep 2011 11:54:42 +1000
Message-ID: <4E642BE2.3080509@mcc.id.au>
To: timeless <timeless@gmail.com>
CC: public-script-coord@w3.org
On 2/09/11 2:21 AM, timeless wrote:
> Looks good to me.
> I'd vote for dropping it if we don't know of any users. (I don't want
> to train that word to this device - bad habits are hard to break!)

I've dropped it now, and required that the Java language binding have 
methods with particular names ("_get", "_set", etc.) for IDL special 
operations that are declared without identifiers.  I think that's more 
consistent with an "ECMAScript first" approach than encouraging 
specification authors to specify "omittable" and an identifier for the 
benefit of other languages.

Received on Monday, 5 September 2011 01:55:21 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:14:04 UTC