W3C home > Mailing lists > Public > public-rdfa-wg@w3.org > January 2011

Re: RDF API thoughts

From: Ivan Herman <ivan@w3.org>
Date: Tue, 11 Jan 2011 15:19:37 +0100
Cc: RDFa WG <public-rdfa-wg@w3.org>
Message-Id: <3D1102C7-F9AF-45F4-AC2A-57AEEFB1CB36@w3.org>
To: Toby Inkster <tai@g5n.co.uk>

just a few remarks/questions

On Jan 11, 2011, at 14:36 , Toby Inkster wrote:

> Other high-level changes unrelated to Notation 3 that should be made:
> 1. Literals are currently allowed to have both a datatype and a
> language. This goes beyond even the Notation 3 data model, so I do not
> see what is gained by allowing this in the RDF API. Literals should be
> forced to pick a camp.
> 2. Drop special support for rdf:PlainLiteral. rdf:PlainLiteral is not
> used much in the wild and was never intended to be - it's a datatype
> used internally by OWL 2 and RIF. Adding special support for it
> complicates implementations for no reason - it should be treated the
> same as any other custom datatype.

Not exactly, and the RDF WG might pick this up. There is a certain amount of mess with plain literals, xs:strings etc, already, and the plain literal has come up because of that. THere is an entry in the charter to, possibly, look at this mess in RDF. I would prefer to keep it in the API

> 3. Move terms, prefixes and profiles into the RDFa API or, better yet,
> drop them altogether. They make the API harder to implement and harder
> to grok while adding very little benefit. For those people who want to
> use prefixes and terms, they can be implemented quite trivially in "user
> space".
> See:
> http://lists.w3.org/Archives/Public/public-rdfa-wg/2010Oct/0131.html

I am not sure. I have been using something like namespaces in RDFLib for many years, I think there is a similar facility in Jena, and it would have been very unhandy not to have that. I would prefer to keep something like that. I agree for profiles, though.

> 4. Move or copy PropertyGroups from the RDFa API into the RDF API. The
> Graph interface should have getItemsByType, getItemBySubject and
> getItemsByProperty methods which return PropertyGroups or arrays of
> them.

I would be happy with that

> 5. Rename PropertyGroup to something like "RDFItem", "RDFResource" or
> "Description", or indeed "FartWarbler" - any name you pick out a hat
> will be better than the status quo.

The status quo was based on the fact that we did not have a better name:-)


> -- 
> Toby A Inkster
> <mailto:mail@tobyinkster.co.uk>
> <http://tobyinkster.co.uk>

Ivan Herman, W3C Semantic Web Activity Lead
Home: http://www.w3.org/People/Ivan/
mobile: +31-641044153
PGP Key: http://www.ivan-herman.net/pgpkey.html
FOAF: http://www.ivan-herman.net/foaf.rdf

Received on Tuesday, 11 January 2011 14:20:22 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 17:05:23 UTC