- From: Niklas Lindström <lindstream@gmail.com>
- Date: Sun, 7 Nov 2010 00:49:50 +0100
- To: public-rdfa-wg <public-rdfa-wg@w3.org>
Hi all! First of all, I really enjoy seeing the progress you make to the RDFa API. You're doing an excellent job! I have a couple of suggestions regarding the API: 1. The name of the interface "PropertyGroup". Since the methods used to retrieve these are named "getItemBy[...]", why is it not named "RDFItem" or similar? Just a detail perhaps, but the naming of things is quite important IMHO. (It could also be called Description, in honor of the "D" in RDF.. ;) ) 2. The PropertyGroup should have an attribute for the subject it represents the properties of ("readonly attribute RDFResource subject;"). 3 a. It would be really convenient to easily get a PropertyGroup for an RDFResource (i.e. IRI:s and BNodes), so I suggest adding a method to RDFResource for getting a PropertyGroup with the given resource as subject, such as "getItem()". This is to avoid having to repeatedly call "document.getItemBySubject(...)" when traversing linked resources. 3 b. If this breaks the layered abstraction (RDFResource being "lower" than PropertyGroup), it might be better to have something like "getItems(...)" on PropertyGroup (either failing or filtering if the retrieved values aren't all RDFResource:s). Background: I have two implementations, one in Java for Sesame and one in Python for RDFLib, which I would like to adapt to this interface. Both of these are generic read/write utilities - not RDFa specific. I have used them a lot with good results, and these suggestions are all based on my experience with that. Best regards, Niklas Lindström
Received on Saturday, 6 November 2010 23:50:39 UTC