W3C home > Mailing lists > Public > public-qa-dev@w3.org > August 2010

Re: Issues installing unicorn

From: Ben Sion <ben@fotegrafik.com>
Date: Thu, 5 Aug 2010 19:11:05 +0800
Cc: public-qa-dev@w3.org
Message-Id: <6BD3E1B2-5411-43A1-8584-C4E88B02AD58@fotegrafik.com>
To: Thomas Gambet <tgambet@w3.org>
Hi Tom,

You're a champion. That worked. I guess I should have analysed the  
build file a bit more closely.

Thanks for the help and keep up the good work.


On Aug 5, 2010, at 1:31 AM, Thomas Gambet wrote:

> Hi Ben,
> We didn't get to write the installation documentation yet. Here is  
> what you should do to get unicorn running quickly:
> hg clone https://dvcs.w3.org/hg/unicorn (you got that right)
> ant retrieve generate_observer generate_tasklist default_conf war
> You'll have 2 warnings during compilation that we will fix eventually.
> The war is in the dist directory. You need to tell your server to  
> unpack war files (for Tomcat there is a unpackWARs="true" property  
> in servers.xml, for jetty you can use a context and add <Set  
> name="extractWAR">true</Set> to it). Alternatively you could use the  
> deployed task instead of the war task. If something goes wrong check  
> the logs under WEB-INF/logs.
> Once the documentation is online you'll have more information on how  
> to configure Unicorn.
> Regards,
> Tom
> Le 04/08/2010 07:55, Ben Sion a écrit :
>> Hi Unicorn developers,
>> Firstly nice work on Unicorn. This is a very important tool. I am  
>> trying
>> to install a local version of Unicorn without much success. I am  
>> new to
>> Mecurial so that may be the source of troubles. After downloading the
>> source. I run the following ant commands:
>> ant retrieve (works fine)
>> ant compile (I tried ant war too and it fails on the compile target)
>> This gives me 94 compilation errors. The first ones relate to the
>> Framework class. I notice that this import statement seems to cause a
>> number of errors:
>> import org.w3.unicorn.tasklist.TUi;
>> When I browse the code online and and in the source I have  
>> downloaded, I
>> notice that this class and package does not exist. Am I missing a  
>> step
>> here or have I downloaded the wrong source?
>> To download the source I tried the following commands. All with the  
>> same
>> result of compilation failure.
>> hg clone https://dvcs.w3.org/hg/unicorn
>> as well as :
>> hg clone --rev 1.0 https://dvcs.w3.org/hg/unicorn
>> Any guidance here would be greatly appreciated.
>> Additional info:
>> OS: Linux
>> JDK: 1.6.0_20
>> ANT: 1.7.1
>> Cheers,
>> Ben
Received on Thursday, 5 August 2010 11:12:43 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:54:57 UTC