W3C home > Mailing lists > Public > public-qa-dev@w3.org > August 2010

Issues installing unicorn

From: Ben Sion <ben@fotegrafik.com>
Date: Wed, 4 Aug 2010 19:55:25 +0800
Message-Id: <ACB4D40E-68C7-445B-B8B4-72A3E725182C@fotegrafik.com>
To: public-qa-dev@w3.org
Hi Unicorn developers,

Firstly nice work on Unicorn. This is a very important tool. I am  
trying to install a local version of Unicorn without much success. I  
am new to Mecurial so that may be the source of troubles. After  
downloading the source. I run the following ant commands:

     ant retrieve (works fine)
     ant compile (I tried ant war too and it fails on the compile  

This gives me 94 compilation errors. The first ones relate to the  
Framework class. I notice that this import statement seems to cause a  
number of errors:
import org.w3.unicorn.tasklist.TUi;

When I browse the code online and and in the source I have downloaded,  
I notice that this class and package does not exist. Am I missing a  
step here or have I downloaded the wrong source?

To download the source I tried the following commands. All with the  
same result of compilation failure.
     hg clone https://dvcs.w3.org/hg/unicorn
as well as :
     hg clone --rev 1.0 https://dvcs.w3.org/hg/unicorn
Any guidance here would be greatly appreciated.

Additional info:
OS: Linux
JDK: 1.6.0_20
ANT: 1.7.1

Received on Wednesday, 4 August 2010 16:12:17 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:54:57 UTC