W3C home > Mailing lists > Public > public-prov-wg@w3.org > August 2012

Re: PROV-ISSUE-480: XSD Validator returns schema parser error when reading prov.xsd [XML Serialization]

From: Stephan Zednik <zednis@rpi.edu>
Date: Wed, 15 Aug 2012 14:29:37 -0600
Message-Id: <ADDF4AB9-45C2-4D52-A492-EF3CB71D61AD@rpi.edu>
To: Provenance Working Group <public-prov-wg@w3.org>
I committed the change, will change ticket status to 'PENDING REVIEW'.

https://dvcs.w3.org/hg/prov/rev/954701ee8fe3

I will close the ticket after I get confirmation from the PROV-XML group that it is validating for everyone.

--Stephan

On Aug 15, 2012, at 2:24 PM, Stephan Zednik <zednis@rpi.edu> wrote:

> Based on the information at http://www.w3.org/TR/xml-i18n-bp/#generic-includeinxsd, if we update the schema so that the import of xml.xsd looks like the following
> 
> <xs:import namespace="http://www.w3.org/XML/1998/namespace" 
>             schemaLocation="http://www.w3.org/2001/xml.xsd"/>
> 
> the schema should be correct.
> 
> I made this change and tested it and the online validator at http://xsdvalidation.utilities-online.info validates the schema as OK.
> 
> I will make the change and commit to hg.
> 
> --Stephan
> 
> On Aug 15, 2012, at 2:08 PM, Provenance Working Group Issue Tracker <sysbot+tracker@w3.org> wrote:
> 
>> PROV-ISSUE-480: XSD Validator returns schema parser error when reading prov.xsd [XML Serialization]
>> 
>> http://www.w3.org/2011/prov/track/issues/480
>> 
>> Raised by: Stephan Zednik
>> On product: XML Serialization
>> 
>> I tried to validate the following sample xml 
>> 
>> <?xml version="1.0" encoding="UTF-8"?>
>> <prov:Agent prov:id="ex:e1" xmlns:prov="http://www.w3.org/ns/prov#" xmlns:ex="http://www.example.com/ns/ex/">
>> 	<prov:type>prov:Person</prov:type>
>> 	<ex:name>Alice</ex:name>
>> 	<ex:employee>1234</ex:employee>
>> </prov:Agent>
>> 
>> against prov.xsd using xmllint and received the following error response 
>> 
>> zednik$ xmllint --noout --schema prov.xsd ../../examples/eg-40-xml-examples-by-term/xml/Agent.xml 
>> warning: failed to load external entity "xml.xsd"
>> prov.xsd:32: element import: Schemas parser warning : Element '{http://www.w3.org/2001/XMLSchema}import': Failed to locate a schema at location 'xml.xsd'. Skipping the import.
>> prov.xsd:360: element attribute: Schemas parser error : attribute use (unknown), attribute 'ref': The QName value '{http://www.w3.org/XML/1998/namespace}lang' does not resolve to a(n) attribute declaration.
>> WXS schema prov.xsd failed to compile
>> 
>> This does not tell me about the correctness of my example XML file against the schema, but seems to imply there are issues with the schema itself.
>> 
>> I followed this up by trying to use an online XSD Validator to get a second opinion.  I am unsure of what online validators are best so I used one of the top ranked results on Google - http://xsdvalidation.utilities-online.info
>> 
>> Validation of the XSD failed with the message, 'src-resolve: Cannot resolve the name 'xml:lang' to a(n) 'attribute declaration' component.'
>> 
>> I am not very experienced in debugging XML schemas.  Does anyone have any ideas?  Is this an actual issue with the schema or am I just using the wrong tools to validate the XSD?
>> 
>> 
>> 
>> 
> 
> 
> 
Received on Wednesday, 15 August 2012 20:30:06 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:58:18 UTC