RE: Comments on 19-Feb-2013 LCWD of Pointer Events

On Mon, Mar 18, 2013 at 1:13 PM, Arthur Barstow <> wrote:
> A few non-substantive comments and Qs re the 19 February 2013 LCWD of Pointer Events:
> * Glossary - I think it would improve readability to move the Glossary to the front of the spec (before the terms are used). Add "hit test" to the Glossary.

Agreed this is a good editorial change to make.

> * 7.{1,2}#1 - these two sections says setPointerCapture and releasePointerCapture can throw a DOMException. As such, perhaps but the definition of these two methods should mention the exception (when pointerId is bogus)

Also agreed, would add clarity.

> * 7.{1.2} - does InvalidPointerId need to be documented in some spec/registry?

No, I do not believe so.

> * 8.1 - first sentence includes "... dispatch a pointer event from for device that ..." and that doesn't read quite right (perhaps there is an extra word in that clause).

Indeed a typo. Should be "...dispatch a pointer event for a device...."

> * 8.1#4 - should "pointerleave, then dispatch a pointerleave event" be "pointerleave, then dispatch a mouseleave event"? (Same question for 8.2#5 i.e. if event is pointerleave, is pointerleave dispatched or mouseleave?)

Another typo. Good catch.

> * 8.2#2 - the text at the end says to dispatch a "mousemove event", should that be "mouseover event"?

No, this is intended to be mousemove. Some sites expect to see at least one mousemove event in when an element is clicked (e.g. the mouse moving over the element before clicking). This provides compatibility with those sites.

Since these are all straightforward editorial improvements, I went ahead and made them in the latest editorial draft. Please let me know if there are concerns. Thanks!


Received on Saturday, 23 March 2013 00:48:07 UTC