Bare values read as "just this value please"

Here's an example we were looking at while discussing the ideal algorithm:

*

Constraints:

{

  width: { ideal: 1280 },

  height: { ideal: 720, max: 1080, min: 360 },

  aspectRatio: { ideal: 1.78 },

}

*It expresses constraints on height and a preference for 1280 x 720 and 
16/9.

We avoided using plain values for clarity.

I still find it highly unintuitive that width: 1280 would mean the same 
as width: {ideal: 1280} here, or aspectRatio: 1.78 for that matter:

*

Constraints:

{

  width: 1280,

  height: { ideal: 720, max: 1080, min: 360 },

  aspectRatio: 1.78,

}
*
A plain value literally is mutually exclusive with {}, almost exactly 
like specifying a value is mutually exclusive with providing ranges 
and/or hints for that value. To me it reads as "just this value please", 
yet users may get cameras that are not 1280 wide or 1.78 aspect here, 
even though these values are specified in the top "required" section.

Add to this that plain values in the advanced array are not ideal, and 
it's a semantic mess.

Is it truly too late to rectify this?

.: Jan-Ivar :.

Received on Friday, 1 August 2014 00:14:18 UTC