Re: Image Capture Proposal, second version

On 2013-02-22 23:30, Mandyam, Giridhar wrote:
> Hello All, Thanks for all the detailed feedback I received on this.
> I've now come up with a second version, which I have enclosed as an
> attachment. I have kept the first version up at
> http://gmandyam.github.com/image-capture if anyone would like to
> compare this one with the previous version.
>

> the UA must fire a FrameGrabErrorEvent event at the onframegraberror event handler (if specified) with a new FrameError object

I commented on this in the last version, but I was a bit unclear. With 
the text:

"fire a simple event named "settingschange" [with a <payload>] [at the 
<object>]"

, I meant <object> to be the ImageCapture object (i.e. the EventTraget). 
The event firing is independent of the corresponding EventHandler 
attribute being set or not. The developer might be using 
addEventListener() to register listeners.

> readonly attribute ImageData imageData;

Reference to canvas spec needed.

----

I your previous mail, you asked for comments on the examples. Here are some:

> 17.1 Taking a picture if Red Eye Reduction is activated

> var videoDevice = mediastream.getTrackByID(0);

If you want a video track, and you don't have a valid track id, you 
should use mediastream.getVideoTracks()[0].

> currentRedEye = new Boolean;
> currentRedEye = false;
> if (pictureDevice.photoSettingsOptions.redEyeReduction)
>     currentRedEye = pictureDevice.photoSettingsOptions.redEyeReduction.value;
> if (currentRedEye == true)
>     pictureDevice.takePhoto();
> }

This block could be simplified to:

if (pictureDevice.photoSettingsOptions.redEyeReduction)
     pictureDevice.takePhoto();

> 17.2 Grabbing a Frame for Post-Processing

> var videoDevice = mediastream.getTrackByID(0);

As above.

> imgData = e.data;

var imgData = e.imageData;

> width = e.width;
> height = e.height;

var width = imgData.width;
var height = imgData.height;

----

BR
Adam

Received on Tuesday, 26 February 2013 08:38:14 UTC