W3C home > Mailing lists > Public > public-media-capture@w3.org > October 2012

Re: Blob URLs for MediaStreams

From: Adam Bergkvist <adam.bergkvist@ericsson.com>
Date: Tue, 9 Oct 2012 13:28:27 +0200
Message-ID: <50740A5B.70106@ericsson.com>
To: "robert@ocallahan.org" <robert@ocallahan.org>
CC: "public-media-capture@w3.org" <public-media-capture@w3.org>
On 2012-10-09 07:26, Robert O'Callahan wrote:
> http://dev.w3.org/2011/webrtc/editor/getusermedia.html#methods-1
> The current draft says that createObjectURL mints a Blob URL for a
> MediaStream. I don't think that is a good idea, since Blobs are static
> objects (an immutable array of bytes), and MediaStreams are a
> constantly-changing stream of media data. So a URL constructed for a
> MediaStream cannot be used everywhere a Blob could be used, for example
> it can't be loaded via XmlHttpRequest.
> So I suggest that a new URL scheme analogous to Blob URLs be defined for
> MediaStreams, say scheme "mediastream". The rest of their behavior, such
> as revocation, can be shared with Blob URLs.

+1 on this.

I think it's wrong that createObjectURL() generates "blob" URLs only. If 
the method should be limited to generate one type of URL only then it 
should be a more general "object" URL (as the name of the method says). 
But don't vote for that. I like the approach with more specific "blob" 
and "mediastream" URLs better.

We had "stream" URLs in our WebRTC prototype (WebKit GTK+) and they were 
very useful, e.g., when selecting the back-end player for the <video> 
element (file player or real-time stream player).

Received on Tuesday, 9 October 2012 11:28:51 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:24:37 UTC