W3C home > Mailing lists > Public > public-ldp-wg@w3.org > January 2013

Re: ISSUE-36: Summary of ways of making containers

From: Nandana Mihindukulasooriya <nmihindu@fi.upm.es>
Date: Wed, 23 Jan 2013 16:34:25 +0100
Message-ID: <CAAOEr1neruye68pfbyTUQ5xqb8u=vuZj0j1nFu4n4fNX6p--BA@mail.gmail.com>
To: "public-ldp-wg@w3.org" <public-ldp-wg@w3.org>

On Wed, Jan 23, 2013 at 4:00 PM, Steve Speicher <sspeiche@gmail.com> wrote:
> This seems to set us up to need a "Factory" predicate for any kind of
> thing that can be created.  Perhaps we could instead say way kind of
> thing can be created in this container.
> For example,
> <> a ldp:Container;
>        ldp:canCreate ldp:Container, oslc:ChangeRequest .
> Then one could look up these Classes to see what they look like.  This
> may be something better for LDP 2.0 (for lack of better name).  I have
> a need for something like this anyway, knowing what kinds of things
> the container accepts.  Disclaimer, the name ldp:canCreate is nothing
> I'm emotionally attached to.

+1. This would be quite useful LDP servers bound to a domain model. Of
course, it can be optional but it when it is present it provides clients
some valuable information.

Best Regards,
Received on Wednesday, 23 January 2013 15:35:11 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 16:17:36 UTC