[Bug 25866] "needkey" event name is misleading

https://www.w3.org/Bugs/Public/show_bug.cgi?id=25866

Jerry Smith <jdsmith@microsoft.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |jdsmith@microsoft.com

--- Comment #3 from Jerry Smith <jdsmith@microsoft.com> ---
I prefer "encryptedmedia" for the same reason Mark lists below.  It seems more
complete and is clear.

We also need to update the needkey event interface and dictionary:

[Constructor(DOMString type, optional EncryptedMediaEventInit eventInitDict)]
interface EncryptedMediaEvent : Event {
  readonly attribute DOMString initDataType;
  readonly attribute ArrayBuffer? initData;
};

dictionary EncryptedMediaEventInit: EventInit {
  DOMString initDataType = "";
  ArrayBuffer? initData = null;
};

-- 
You are receiving this mail because:
You are the QA Contact for the bug.

Received on Monday, 30 June 2014 16:52:07 UTC