W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > May 2011

[Bug 12820] Hi guys, I am finding it frustrating that security features prevent me from writing a useful app in HTML5 that will run solely on the client machine. It seems that windows can talk to each other if their is a parent / child relationship - UNLESS you load

From: <bugzilla@jessica.w3.org>
Date: Mon, 30 May 2011 21:02:19 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1QR9bP-0002xD-Nu@jessica.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=12820

Boris Zbarsky <bzbarsky@mit.edu> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |bzbarsky@mit.edu
            Summary|Hi guys                     |Hi guys, I am finding it
                   |                            |frustrating that security
                   |                            |features prevent me from
                   |                            |writing a useful app in
                   |                            |HTML5 that will run solely
                   |                            |on the client machine. It
                   |                            |seems that windows can talk
                   |                            |to each other if their is a
                   |                            |parent / child relationship
                   |                            |- UNLESS you load
            Summary|I am finding it frustrating |
                   |that security features      |
                   |prevent me from writing a   |
                   |useful app in HTML5 that    |
                   |will run solely on the      |
                   |client machine. It seems    |
                   |that windows can talk to    |
                   |each other if their is a    |
                   |parent / child relationship |
                   |- UNLESS you load           |

--- Comment #1 from Boris Zbarsky <bzbarsky@mit.edu> 2011-05-30 21:02:18 UTC ---
The problem you're running into is that the browser has no way to tell apart
"user installed an app" and "user just saved a web page" in your case.... 
That's not an HTML issue per se.

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Monday, 30 May 2011 21:02:20 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 16:31:10 UTC