W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > November 2009

[Bug 8268] XMLHttpRequest fails for documents with named entities due to doctype

From: <bugzilla@wiggum.w3.org>
Date: Thu, 12 Nov 2009 16:17:23 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1N8cMN-0005al-Ub@wiggum.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8268





--- Comment #8 from Aryeh Gregor <Simetrical+w3cbug@gmail.com>  2009-11-12 16:17:23 ---
(In reply to comment #7)
> (In reply to comment #6)
> > Currently, validator.nu raises an error, which is wrong per the spec.
> 
> I pasted the following in the text area on http://html5.validator.nu/ and I got
> a warning only.
> 
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
> "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
> <html>
> <head>
> <title></title>
> </head>
> <body>
> <p></p>
> </body>
> </html>
> 
> I get an error if I try the Transitional doctype, though, as I should per spec.

Okay, it seems like http://validator.nu/ raises an error (followed by lots more
errors because it interprets it as XHTML 1.0 Strict), while
http://html5.validator.nu/ raises only a warning.  So that's okay, but the
warning message could maybe be clearer about why you might want to do this.


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Thursday, 12 November 2009 16:17:26 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 20:01:05 UTC