W3C home > Mailing lists > Public > public-html-bugzilla@w3.org > November 2009

[Bug 8238] Add support for X3D

From: <bugzilla@wiggum.w3.org>
Date: Sun, 08 Nov 2009 16:45:52 +0000
To: public-html-bugzilla@w3.org
Message-Id: <E1N7Atk-0001if-5H@wiggum.w3.org>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=8238


Krzysztof Maczyński <1981km@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |1981km@gmail.com




--- Comment #5 from Krzysztof Maczyński <1981km@gmail.com>  2009-11-08 16:45:51 ---
They usually use noNamespaceSchemaLocation, since they believe (as mentioned in
http://www.web3d.org/x3d/publiclists/x3dpublic_list_archives/0712/msg00130.html
and a few other places, basically wherever this question comes up) specifying a
schema entails namespacing and only for integration with other XML vocabularies
do they care about satisfying the formal requirement of making it explicit, in
which case they suggest xmlns:prefix="schema-URI", i.e. the namespace name is
identical to the schema's URI. This belief is an interpretation which has been
suitable so far for that community but it isn't shared by people outside of it,
so as the right way forward I see asking them to specify that namespace in the
next version of their XML encoding. (It seems that so far only individuals have
done that, so it hasn't gained enough priority within their work.)


-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Sunday, 8 November 2009 16:45:57 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 20:01:05 UTC