Re: [css-houdini-drafts] [worklets] (bikeshedding time!) import() name is potentially confusing...

The CSS Working Group just discussed Worklets, and agreed to the following resolutions:

```
RESOLVED: import() to be renamed to addModule()
```

<details><summary>The full IRC log of that discussion</summary>

```
<eae> Topic: Worklets
<philipwalton> present+
<Rossen> present+
<skk> present+
<dbaron> Github topic: https://github.com/w3c/css-houdini-drafts/issues/374
<SimonSapin> Simon Sapin, Mozilla
<eae> iank_: There is the feedback from various people that the import method on worklets is confusing, similar to import statement in javascript which is somewhat similar but not really. Any preferences for another name? Looking for feedback.
<eae> iank_: Leading proposal is Worklet.spawn
<eae> Rossen: What is the history here? Feedback from people trying to use it?
<eae> iank_: Mostly feedback from annevk.
<eae> iank_: The main push back was that the script can end up running multiple global scopes which is a bit unique.
<eae> iank_: This was seen as confusing.
<eae> philipwalton: Definitively not import.
<eae> iank_: Any other preferences?
<eae> philipwalton: Could you clarify what it would be spawning if we go with spawn.
<eae> iank_: It is not really creating anything new, it loads a script into multiple global scopes. Not really spawning.
<eae> iank_: Another suggestion is loadModule. Primary push back there s that it looks similar to system.import which loads into the current global scope.
* astearns encabulate
<eae> philipwalton: Any disucssion around how this would interact with ES6 modules?
<eae> iank_: Would just work.
<eae> philipwalton: Other workers have the importScript function?
<eae> iank_: Yes and that would load into the current global scope.
<eae> iank_: dbaron, any preferences?
<eae> dbaron: not really
<eae> philipwalton: If the only difference is that it loads into multiple global scopes the name should reflect that.
<eae> dbaron: When you described what it does you used the word load....
<eae> iank_: Propose that we switch it to loadModule and see if there is any pushback for that specific name.
<eae> Rossen: Sounds good to me.
<eae> ???: I don't like spawn.
<eae> Sounds like ES6 load module but does somehting differently, my only concern.
<astearns> s/???/jack/
<eae> iank_: you need to have at least one global running. Your code will get immediately executed but if another global scope is spawn it'll load into that as well.
<astearns> s/Sounds like/flackr: Sounds like/
<eae> iank_: The paint specification for instance requires at least two global scopes at all times (unless under memory pressure).
<eae> rbyers: Perhaps register instead?
<eae> flackr: addModule?
<eae> iank_: I could live with addModule
<eae> iank_: Will update github issue to propose addModule and await feedback
<eae> Rossen: addModule is the final proposal for now?
<eae> philipwalton: I kind of like registerModule better but add is fine
<eae> Rossen: In summary, addModule is much preferred over import or spawn. Unless there are other proposal I suggest we resolve to rename it to addModule. Any objections?
<eae> RESOLVED: import() to be renamed to addModule()
```
</details>


-- 
GitHub Notification of comment by css-meeting-bot
Please view or discuss this issue at https://github.com/w3c/css-houdini-drafts/issues/374#issuecomment-294633752 using your GitHub account

Received on Tuesday, 18 April 2017 00:20:33 UTC