Re: compassCalibrated vs accuracy?

On Feb 14, 2011, at 11:27 AM, Andrei Popescu wrote:

> On Mon, Feb 14, 2011 at 7:04 PM, Dean Jackson <dino@apple.com> wrote:
>> Hi,
>> 
>> One of the engineers who worked on Apple's Core Motion API passed on some feedback related to compassCalibrated. He suggests that a float property called "accuracy" would be better suited - taking a value between 0 and 1.
>> 
>> The reasoning is that a developer shouldn't really be concerned with calibration. All they really need to know is the accuracy of the data they are seeing. Also, future hardware may not need calibration, but will still have variance in accuracy.
>> 
>> A value of 0 for accuracy could still trigger a dialog by the system asking for compass calibration (on iOS this prompts the user to do a figure-8 movement with the device). A value of 1 would mean that your data is as accurate as possible. Anything in between could be used in the UI to suggest you're not getting perfect data.
>> 
> 
> This sounds reasonable, although I am wondering what exactly would the
> application do with the numerical value. The above usecase seems to
> split the values into 3 buckets:
> 
> 0 - calibration needed,
> (0, 1)  - data isn't perfect,
> 1 - data is as accurate as possible
> 
> which makes me wonder if it wouldn't be simpler if we rather had
> 'accuracy' as an enumeration (e.g. ACCURACY_LOW/MEDIUM/HIGH) ? Or are
> there a usecases where the actual numeric value could be used for
> something other than prompting the user to calibrate?

I don't have strong feelings either way, but here's an example of what we do in iOS for compass heading. We currently give a numerical accuracy value in degrees. A negative value means we have no estimate. A positive value is the +/- in the heading, with 45 degrees being the worst. For example, you'd be able to tell the user the heading is NE +/- 15deg.

I realise this isn't what I suggested, as in it isn't 0-1, but you can decide if you think it is helpful :)

If we do go with enumeration, then I think we want more than 3 (you would probably want to add UNKNOWN at least). I believe the feedback has two core parts: to avoid the term calibration, and to give some variance.

Dean


> 
>> I don't want to hold up FPWD for this comment. Please consider it simply feedback on the draft.
>> 
> 
> Thanks for considering this :) My guess is that such a change wouldn't
> hold up FPWD.
> 
> All the best,
> Andrei

Received on Monday, 14 February 2011 19:37:14 UTC