W3C home > Mailing lists > Public > public-fx@w3.org > October to December 2013

Re: [web-animations] Naming of timing groups in the API

From: Tab Atkins Jr. <jackalmage@gmail.com>
Date: Wed, 6 Nov 2013 18:12:14 -0800
Message-ID: <CAAWBYDBkkur7WN4AJ9xm_WWM0uWpcpG==FL29MXSziBmeGH1-A@mail.gmail.com>
To: Kevin Doughty <CocoaHeads@kxdx.org>
Cc: Brian Birtles <bbirtles@mozilla.com>, "public-fx@w3.org" <public-fx@w3.org>
On Wed, Nov 6, 2013 at 6:03 PM, Kevin Doughty <CocoaHeads@kxdx.org> wrote:
> On Nov 6, 2013, at 7:15 PM, Tab Atkins Jr. <jackalmage@gmail.com> wrote:
>> Parallel is a terrible word to spell. Never put it in an API name.
> How about AnimationGroup and AnimationSequence or AnimationChain?

Well, "Sequence" and "Chain" both mean "not parallel".

I'm fine with SyncGroup.  Yeah, there's punning with "synchronous",
but if you can avoid that it's well-named - people use "sync" for
synchronizing plenty.

Received on Thursday, 7 November 2013 02:13:01 UTC

This archive was generated by hypermail 2.4.0 : Friday, 17 January 2020 19:49:47 UTC