Re: [web-animations] Naming of timing groups in the API

Dear all,

I thought I'd open up this thread again.[1] Some people would like to 
write code samples for the Web Animations API and since we know ParGroup 
and SeqGroup are going to change names at some point, it would be good 
to try to fix them now or at least get them a little closer to their 
final naming before littering the Internet with incorrect naming like we 
did with flexbox.

Here's my latest suggestion:

   SyncGroup and SequenceGroup

Some explanation:

- SyncGroup is the old ParGroup. There was some concern about "Parallel" 
being unclear. Also, SyncGroup is four characters (~30%) shorter to type 
than "ParallelGroup".

- SequenceGroup is the old SeqGroup. It's longer, but the savings from 
SyncGroup go some way to compensating for this. It's more clear. 
'Sequence' alone is probably too generic since it already has other 
meanings (e.g. an array-like thing in WebIDL).

- I suggest when we map these to SVG we could use <sync> and <sequence> 
instead of <par> and <seq>. This is both to make life easier for authors 
working with markup and script and because 'par' and 'seq' are not 
obvious in meaning. Making the mapping to SVG straightforward is also 
why I've steered away from any name using 'set' or just 'group' since 
SVG already has <set> and <g> (=group).

- We *could* make SequenceGroup a subclass of SyncGroup but I think that 
can be a separate discussion and I'm not yet persuaded it's a good idea.

So in practice, code might look like:
     new SyncGroup([
       new SequenceGroup([new Animation(...), new Animation(...)]),
       new Animation(...)

And SVG code:

       <animate ... />
       <animate ... />
     <animate ... />


Best regards,


[1] The original thread is here for anyone who lost it:

Received on Wednesday, 6 November 2013 01:18:24 UTC